Stay in the know and up-to-date on what's happening in the Blackbaud Community.

Holly's Helpful Hints: How To Find People

Recently I've seen a lot of conversations throughout the community from members seeking to connect with people in their geographic area, nonprofit vertical, Blackbaud solution(s), etc. and I realized I haven't written a helpful hint about one of my favorite parts of the Community: the Member Search page!

I've said time and again, the most incredible thing about the Blackbaud Community is its members. The collective knowledge of our members is staggering so it's no wonder that the top activities in the site all have to do with networking!

Here's how to start connecting with other community members.

Locate the members menu at the top of the community and select "member search."

8f9a227cd98b2406248eaf4efcaf3b14-origina
Fun tip, if you just click on the word "members" at the top of the menu, it will also take you to members search.

Once on the member search page, you have two search options. You can either search by a person's name using the members search bar:
7d539ab3a758eb6628e4e6cf593eb5af-origina

Or you can search using the series of search filters, located on the right side of the page (this screenshot is just a sample of the first sets of filters):
bcbc00446dfdb945ef9a4ef702a60395-origina

Remember, the results of our members search are only as good as the information community members provide in their profiles. If you haven't updated your profile or product interest in awhile, now's the time! You can do this from your MyCommunity page.
Posted by Holly Herbert on Jan 13, 2017 10:48 AM America/New_York

Leave a Comment

Log in to post a comment.

280 as of right now! Wonder if that will grow if people fill in more of their profile info!

UPDATE
The criteria has changed since I answered this on 100 miles of 46202 and animal welfare and I don't think the non-profit or vertical had registered yet when I got the results. So just the 100 miles from 46202 resulted in 280 and this morning it is up to 281 - I was curious - I'll answer again.

My new answer based on anyone in the community who works in an arts and cutlure organization as a database administrator, using Altru, within five miles of 80238.
is 2
  • Posted Fri 13 Jan 2017 05:26 AM EST
RE data admin with 100 miles of 46202 is 29, but zero are animal welfare when I plug in the criteria. ?

Still on my wish list to have a 500 mile criteria for those of us in more 'rural' areas. :)
  • Posted Thu 12 Jan 2017 02:12 PM EST
I didn't get any results
  • Posted Thu 12 Jan 2017 02:19 PM EST
I get 0 results
  • Posted Thu 12 Jan 2017 02:21 PM EST
I've reworded my testing criteria in the post. Try again. The search definitely returns results!
  • Posted Thu 12 Jan 2017 02:21 PM EST
I have 0 results as well, when entering all the criteria.
  • Posted Thu 12 Jan 2017 02:29 PM EST
I get 0 results as well
  • Posted Thu 12 Jan 2017 02:30 PM EST
Zero based on the criteria.
Different criteria, Altru, membership management, within 100 miles of 95110 = 5
Using the new criteria: 2, Christopher Wink and Gilliam Armstrong
I use Chrome
  • Posted Fri 13 Jan 2017 12:45 PM EST
I get 0 results. It goes from 61471 to 544 once I check Animal Welfare, then to 225 when adding DBA, then to 94 when adding RE, and then to 0 when I add in the radius criteria. I get 280 with just the radius criteria. (And 29 DBAs using RE in that radius...but adding Animal Welfare returns 0 again.)
  • Posted Thu 12 Jan 2017 02:37 PM EST
Nobody, not a one!
  • Posted Thu 12 Jan 2017 02:41 PM EST
I got one result if I removed RE from the criteria, else zero.
  • Posted Thu 12 Jan 2017 02:42 PM EST
Thanks, Holly! I have played with this area quite a bit, but also have told others about it who knew nothing of it. I am also still getting zero results, even when I expand it out to be 1000 miles instead of 100. When I just used animal welfare and 100 miles from ZIP 46202, which I verified is correctly typed by you (it's not 42602, for example) I get only 7 results, then when I add database administrator, it drops to zero results even before adding the RE restriction. What are we doing wrong?
  • Posted Thu 12 Jan 2017 02:58 PM EST
or do we maybe have restrictions on our profiles that you don't, Holly?
  • Posted Thu 12 Jan 2017 02:59 PM EST
I also get 0 results. This person is very elusive.
  • Posted Thu 12 Jan 2017 03:17 PM EST
got 0 based on the criteria
  • Posted Thu 12 Jan 2017 03:50 PM EST
Hooray for finding bugs on the site with a blog contest!! Turns out, the 1 member that set of search criteria was finding doesn't surface for non-admins. So, after extensive testing, I've updated the blog post with new criteria that we know return results... Let's try this again, y'all!! Good luck and THANK YOU for helping us figure out this super weird glitch in our system.
  • Posted Thu 12 Jan 2017 03:57 PM EST
Are we searching for someone specific?!?!?! I get two people! Christopher Wink and Gillian Armstrong! I'm adding them because they seem interesting! LOL
  • Posted Thu 12 Jan 2017 04:24 PM EST
Carley, you're practicing with our search filters and letting me know how many you find using the criteria I shared. Everyone who provides the right answer will be entered into a drawing for a sweet prize!
  • Posted Thu 12 Jan 2017 04:29 PM EST
2 with revised criteria.
  • Posted Thu 12 Jan 2017 07:04 PM EST
Hi Holly...I tried again this morning and as soon as I put in ANY Search criteria I get 0 results (this is new since yesterday). When I go to the Member Search page I see that there are 61613 members. When I select any of the of the Search filters or type in a name I receive 0 results.
UPDATE - I tried again just now (3 hours since unsuccessful attempt) and receive 2 results :-)
  • Posted Fri 13 Jan 2017 11:31 AM EST
Thanks for letting me know, Shelley! I have reached out to our vendor and will continue to explore this issue. It is a high priority issue for us and I hope to be able to share a resolution soon.
  • Posted Fri 13 Jan 2017 10:50 AM EST
Thanks for your attention to the bugs! I thought this helpful hint was posted because the bugs were fixed. I think I mentioned them previously in another post (or dreamed I did). I will test later!
  • Posted Fri 13 Jan 2017 11:01 AM EST
Thanks, Sunshine! What we're seeing is that the search experience is different for different community members (even outside of admins). So we're trying to narrow in on why some community members are able to use our filters and find people easily and others cannot. Thanks for testing and I will continue to respond with feedback/updates in this comment thread.
  • Posted Fri 13 Jan 2017 11:04 AM EST
I tried everything in order, with the first 3 items getting the list down to 99, and then nothing happens when I add the postal code. If I take out 'Altru' (after adding the postal code) then the list drops down to 2. It stays at 2, if I add 'Altru' back in.
  • Posted Fri 13 Jan 2017 11:08 AM EST
Using the search filters to locate anyone in the community who works in an arts and cutlure organization as a database administrator, using Altru, within five miles of 80238 - I get 2 members.
  • Posted Fri 13 Jan 2017 11:12 AM EST
I got 2 members within 5 miles of 80238, working in arts & culture who is a DBA working in Altru!
  • Posted Fri 13 Jan 2017 11:13 AM EST
I ended up with 2 - Christopher Wink & Gillian Armstrong
  • Posted Fri 13 Jan 2017 11:33 AM EST
I get 2 results using the criteria above. When searching for users in the UK, with no other filters, I get only 1 result (not the same user as either of the ones that were returned by the first test).
  • Posted Fri 13 Jan 2017 11:34 AM EST
Thanks, Alan. That's a good data point to have as well.
  • Posted Fri 13 Jan 2017 11:35 AM EST
With the new set of criteria, I get 2.

With the old set, I still get 0. I know in the Champions Hub, some features work from my home/personal computer that don't work from my computer in the office. Same browser. Don't remember if I ever tested a different browser on that one. But perhaps that's part of what's causing this problem?
  • Posted Fri 13 Jan 2017 11:44 AM EST
Thanks, Jen! Good to know. Out of curiosity, what browser(s) do you typically use?
  • Posted Fri 13 Jan 2017 11:46 AM EST
I get 2!
  • Posted Fri 13 Jan 2017 12:08 PM EST
We have a result of 2!!
  • Posted Fri 13 Jan 2017 12:32 PM EST
Use the search filters to locate anyone in the community who works in an arts and cutlure organization as a database administrator, using Altru, within five miles of 80238.

I get 2 results

When I change the search results to include the zip code where I work, and have all roles checked, I do not come up as a member. Other people at my site come up. Why don't I show up and how can I fix this?

If I search for my name, with nothing checked and no zipcode, I come up. If I put anything in the filters, I do not show up. Weird.
  • Posted Fri 13 Jan 2017 12:54 PM EST
The only filter showing is location.
  • Posted Fri 13 Jan 2017 12:34 PM EST
I got the 2 that we now seem to be expecting, Christopher & Gillian, with the new search criteria. I use Internet Explorer, fairly exclusively, since that's what my hospital system lets us use. With the old search criteria, I still get zero people coming up. I can see all the member search areas you are mentioning in your post.
  • Posted Fri 13 Jan 2017 12:51 PM EST
Vicki, it looks like you haven't filled out your member profile in the community. We don't auto-populate any information about you when you join, so our search is reliant on the information our members share. You can edit/update your profile here: https://community.blackbaud.com/mycommunity/edit/profile
  • Posted Fri 13 Jan 2017 12:50 PM EST
I found 2
  • Posted Fri 13 Jan 2017 01:06 PM EST
My search found 2 members, however neither is a database administrator. One is a Director of Visitor Services, the other a Database Specialist
  • Posted Fri 13 Jan 2017 01:30 PM EST
I found two, Christopher Wink and Gillian Armstrong
  • Posted Fri 13 Jan 2017 02:02 PM EST
I received 2 results for the test run.
  • Posted Fri 13 Jan 2017 02:26 PM EST
When I try to search users with multiple product interests, it narrows the search with each product I select. I want to see users that have ANY of those product interests, but the filter seems to read ALL.
  • Posted Fri 13 Jan 2017 02:30 PM EST
That's accurate, Sunshine. Our filters work on AND logic, so as you apply filters you're adding " and new filter" to the results.
  • Posted Fri 13 Jan 2017 02:32 PM EST
Okay, thanks!
  • Posted Fri 13 Jan 2017 03:08 PM EST
Hi everyone! I promised an update on the member search situation, so here it is. :)

I spoke with our vendor today and while we seem to have worked out most of the issues that were originally causing bad returns, I did learn a couple of things:

1. If you have restricted access in your privacy settings (to friends or no one), that may impact search results. We are digging into which field(s) cause this, but there seems to be a link between search and privacy.
2. Using only a country filter will not return results. The ideal methodology is to use a postal code and country. An alternative is to look within a large distance of a country (e.g 100 miles of United Kingdom, 1000 miles of Canada). These searches will return results.
3. There are a couple of other things we're working out from the admin side of things. Once we have all of this figured out, I will rewrite the post above and republish with updated info, tips, and tricks.

Thank you for your patience and your help uncovering and exploring this issue.

Holly
Community Manager
  • Posted Wed 18 Jan 2017 03:42 PM EST
I see 20 members within a 5 miles of 80238 but I don't see the Search Filters options to choose Job Role(s), etc. Where is this located?
  • Posted Mon 23 Jan 2017 02:47 PM EST
Hi Krys, I just checked your account and did a quick update on it. Can you see the filters now?
  • Posted Mon 23 Jan 2017 02:51 PM EST
I can only search with radius of postcode/country. No other filters appear. Results are 20 within 5mi of 80238.
I'm using IE10 and working out of Aus.
Also, searching for all users with 1000mi of Australia leads to 4 results. Changing that to be 1000mi of Melbourne, Australia, leads to 25.
  • Posted Mon 23 Jan 2017 07:30 PM EST
Came back with 2 members using this criteria
  • Posted Tue 24 Jan 2017 08:38 AM EST
I only get the zip code, country and miles...no other filters come up.
  • Posted Tue 24 Jan 2017 09:33 AM EST
Hi everyone! Thanks for continuing to test. I've made a few more changes to the search page. Please take a minute to go test and let me know if you:
1. Can see lots of filters on the right side (you will need to be logged into the site for this)
2. Can return 2 people if you use the search criteria in the blog post above.

Thanks again! We're getting close to getting this resolved!
  • Posted Tue 24 Jan 2017 10:19 AM EST
Hi Holly
As suggested, I can confirm that I am logged in and the filters have appeared. Once I select a filter, results goes to zero. If I deselect the filter, results remain at zero. Refreshing the page leads to 61588 results. Entering a filter by proximity to the postcode above (80238) results in zero.
Good luck with the debugging!
  • Posted Tue 24 Jan 2017 04:43 PM EST
Hi Andrew! Thanks for the feedback. I've made another update to the search page. It looks like you should be able to get more search results now. I tested a couple things:

If you click on the "Animal Welfare" filter, you should now see about 549 results.
Clear filter.
If you click on the Events Management filter, you should now see about 2682 results.
Clear filter.
If you click on the Altru filter, you should now see about 658 results.
Clear filter.
If you click on Animal Welfare+Events Management+Altru filters, you should now see about 14 results.
Clear filters.
If you search within 100 miles of "Australia" you return about 3 results.
If you search within 1000 miles of "Australia" you return about 4 results.

I'm going to keep working on this, but it looks like we're making progress. Thank you for your feedback. It's super helpful.
  • Posted Wed 25 Jan 2017 12:10 PM EST
Holly, sorry I haven't been back to read more posts on this after your question...I use Mozilla Firefox for all work-related stuff.
  • Posted Wed 25 Jan 2017 07:32 PM EST
Hi Holly
It works now! Thanks for fixing the bugs...
I can now bring up the two results!
  • Posted Mon 30 Jan 2017 06:22 PM EST
This is a great way to connect. I will have to run the test suggestion, thank you.
  • Posted Mon 20 Feb 2017 10:17 AM EST

Categories