Subscribe to this blog to receive periodic product release announcements for developers and tips and tricks for using API.

TLS 1.0 Disablement For SKY API

What is happening?

Blackbaud is requiring an upgrade to TLS 1.1 or above in order to align with industry best practices for security and data integrity set by the Payment Card Industry (PCI) Security Standards Council. On March 15, 2018, we will disable the TLS 1.0 encryption protocol, which will prevent apps still using it from accessing Blackbaud SKY APIs and services.

 

When is it happening?

March 15, 2018: TLS 1.0 will be disabled. All developers must upgrade to TLS 1.1 or 1.2.

 

What is TLS?

TLS stands for “Transport Layer Security.” It is a protocol that provides privacy and data integrity between two communicating applications. It’s the most widely deployed security protocol used today, and is used for web browsers and other applications that require data to be securely exchanged over a network. TLS ensures that a connection to a remote endpoint is the intended endpoint through encryption and endpoint identity verification. The versions of TLS to date are TLS 1.0, 1.1, and 1.2.

 

What do I need to do?

If you are currently using TLS 1.0 to access SKY API, you will need to upgrade to TLS 1.1 or 1.2 to ensure uninterrupted access.

 

Apps will experience issues accessing SKY API using languages, frameworks, or client libraries which do not support TLS 1.1 or TLS 1.2, or which have been configured to disable these protocols.

 

You are encouraged to confirm your development platform’s compatibility with its documentation and test compatibility with TLS 1.1 or TLS 1.2 before TLS 1.0 is disabled.

 

Where can I learn more?

For more details and FAQs, please refer to the Blackbaud TLS upgrade resources.

Posted by Dan Bowman on Mar 1, 2018 7:29 PM America/New_York