Subscribe to this blog to receive announcements about best practices.

Having Issues Signing Into Blackbaud ID On Internet Explorer 11? Check Your Browser's Security Settings

e628c178f14cf924e8def8cb4438ca92-huge-ieSimilar to the earlier post about Google Chrome, you may experience an issue when you sign in to your Blackbaud ID or Blackbaud solution on Microsoft Internet Explorer 11. If you're prompted to sign in again and again, or if you encounter a Sorry, something went wrong error, adjust your browser's security settings.

1. In Internet Explorer 11, select Tools (the cog), Internet options.
2. On the Security tab, select Custom level...
3. Under Miscellaneous, for Access data sources across domains, select Disable.
4. Select OK and OK.

If you continue to experience this or another issue, please contact Blackbaud Support so we can look into it. Thanks!
Posted by Steve Stegelin on Apr 1, 2019 1:28 PM America/New_York

Leave a Comment

Log in to post a comment.

Thanks for this!!!
  • Posted Mon 01 Apr 2019 01:31 PM EDT
Thank you.
  • Posted Fri 05 Apr 2019 03:25 PM EDT
Thanks
  • Posted Wed 10 Apr 2019 11:51 AM EDT
thank you
  • Posted Wed 24 Apr 2019 03:28 PM EDT
Hi all, We finally just had to move to Chrome because receipt printing is vital to our front desk staff. Thank you,
  • Posted Tue 30 Apr 2019 01:06 PM EDT
Good to know! Always helpful to have these tips/troubleshooting notes.
  • Posted Thu 15 Aug 2019 11:07 AM EDT