Subscribe to this blog to know when there is a new announcement.

FIMS 14.64 Is Available!

FIMS 14.64 is now available! This update resolves issues and includes a required security certificate update. For release details, download the FIMS 14.64 Release Notes from the FIMS How-To page.

  • Host*Net clients were updated to version 14.64 on Saturday, October 20th, 2018.
  • On-Premise clients on version 14.60 or later can update to 14.64 by downloading the zip file from the FIMS section on Blackbaud Downloads and following the steps in the FIMS Upgrade Guide.


IMPORTANT:  On-Premise clients who use Progress 11 with DonorCentral v2 or v4 MUST upgrade to 14.64 BEFORE November 4th, 2018.

If you use Progress 11 and are on DonorCentral v2 or v4 but do not upgrade by November 4th, FIMS will be unable to connect to DonorCentral.  This means you will be unable to pull suggestions from or upload Fund Statements. The required security certificate to keep FIMS and DonorCentral v2 or v4 connected is automatically installed when you upgrade to FIMS Version 14.64.

If you plan to upgrade to Progress 11 and still use DonorCentral v2 or v4, you will need FIMS 14.64 to continue FIMS to DonorCentral v2 or v4 connectivity after upgrading to Progress 11.


If you have questions or need assistance, please contact Support. 
Online:                 Visit Case Central at https://www.blackbaud.com/casecentral/casesearch.aspx. Click the Case tab at the top and click Create New Case.
Phone:                 (800) 256-7772 
Support Hours:   M-F, 8:30 am – 8:00 pm ET

Posted by Colleen Gutierrez on Oct 23, 2018 3:35 PM America/New_York

Leave a Comment

Log in to post a comment.