Subscribe to this blog for news and announcements about Altru.

Reminder: TLS Upgrade Preparation

As a reminder, in preparation for upcoming changes to PCI requirements, Blackbaud will begin disabling TLS 1.0 across its solutions beginning today, March 15, 2018.

The PCI Council has released an update to the PCI Data Security Standards. Per the new requirements, TLS version 1.0 will be considered obsolete as of June 30, 2018, and only versions 1.1 and higher will be supported going forward. The TLS encryption protocol upgrade is a mandatory, industry-wide security update, and affects a wide range of software solutions in your environment, not just Blackbaud solutions. Disabling the TLS 1.0 encryption protocol in our solutions beginning today allows us to complete development and testing prior to the PCI Council’s June 30, 2018 deadline. 

Because Altru is a cloud solution, hosted by Blackbaud, you are always current with the latest security requirements and don’t need to take any steps to upgrade your software. However, you will need to ensure that your OS and browsers have been upgraded to support TLS 1.1 and higher, and we recommend that you notify your constituents of this as well. As a reminder, we ask that Altru users take the following actions to ensure you have continued access to your Blackbaud solutions.
  To access additional resources, and for more information on these changes, please visit our TLS Upgrade Preparation page on Blackbaud.com.
Posted by Jillian Lewis on Mar 15, 2018 3:51 PM America/New_York